Intégrer du VLAN dans un réseau local géré par un RB600A pour faire fonctionner une Freebox HD en filaire

Depuis l'écriture de mon billet FreeBox HD et reseau personnel mon architecture personnelle à bien changé. Exit le Linksys WRT54G sous DD-WRT, il a été remplacé par un Mikrotik RB600A tournant sous Router OS 4.10 Adieu le Netgear GS608, remplacé par son cousin plus performant le Netgear GS108T

Je vais donc détailler ici comment mettre en place un réseau local VLANisé pour faire fonctionner le boitier HD de la Freebox sans passer par le MiMo ni le CPL mais par un switch gigabit.

Commençons par détailler le réseau d'une façon “simple”.

[ Freebox ]
|
`-- [ Mikrotik RB600A ]
    |
     `-- [ NetGear GS108T ]
         |
	 |-- [ Freebox HD ]
	 |-- [ PC1 ]
	 `-- [ PC1 ]

Considérant que nous avons la configuration de base indiquée sur mon précèdent article dédié au RB600A (Configurer un RB600A pour un réseau local simple avec WiFi nous allons donc la modifier quelque peu.

Rajouter des VLAN au RB600A

/interface vlan
add arp=enabled comment="" disabled=no interface=ether2 l2mtu=1596 mtu=1500 name=ETHER2_VLAN100 use-service-tag=no vlan-id=100
add arp=enabled comment="" disabled=no interface=ether2 l2mtu=1596 mtu=1500 name=ETHER2_VLAN1 use-service-tag=no vlan-id=1
add arp=enabled comment="" disabled=no interface=ether1 l2mtu=1596 mtu=1500 name=ETHER1_VLAN100 use-service-tag=no vlan-id=100

Remarquez la variable “use-service-tag” forcée sur “no”, l'explication est très simple :
use-service-tag=no : ethertype 802.1q
use-service-tag=yes : ethertype 802.1ad

Comme nous ne souhaitons pas avoir nos trames en 802.1ad mais en 802.1q nous n'activons pas l'option.

Maintenant il faut une adresse IP sur le VLAN que nos PC utiliserons.

Nous remplacerons donc la ligne suivante de mon précédent guide :

/ip address
add address=192.168.X.254/24 broadcast=192.168.X.255 comment="ether2" disabled=no \
    interface=ether2 network=192.168.X.0

Par :

/ip address
add address=192.168.X.254/24 broadcast=192.168.X.255 comment="ETHER2_VLAN1" disabled=no \
    interface=ETHER2_VLAN1 network=192.168.X.0

/!\ Attention si vous modifiez le routeur par cette interface que vous reconfigurez, vous vous tirez une balle dans le pied directement, je conseille donc de configurer via le WiFi puisque nous n'allons pas toucher la configuration de cette interface. /!\

Il faudra aussi modifier la configuration du serveur DHCP :

/ip dhcp-server
add add-arp=yes address-pool=dhcp_ether2_pool authoritative=after-2sec-delay \
    bootp-support=static disabled=no interface=ether2 lease-time=1d name=dhcp_ether2

Par :

/ip dhcp-server
add add-arp=yes address-pool=dhcp_ether2_pool authoritative=after-2sec-delay \
    bootp-support=static disabled=no interface=ETHER2_VLAN1 lease-time=1d name=dhcp_ether2_vlan1

(Notez que pour l'exemple et la simplicité je ne vous fait pas modifier les noms des pools DHCP.

Rajoutons les Bridges

Nous allons donc faire un pont/bridge entre le VLAN100 récupéré sur Ether1 et l'amener sur Ether2

/interface bridge
add arp=enabled auto-mac=yes comment="Bridge VLAN100" disabled=no name=BRVLAN100
/interface bridge port
add bridge=BRVLAN100 comment="" disabled=no interface=ETHER2_VLAN100
add bridge=BRVLAN100 comment="" disabled=no interface=ETHER1_VLAN100

Configurer le Switch

Sur le Switch (dans le cas présent un NetGear GS108T) il faudra donc rajouter dans l'interface le VLAN100 puisque le VLAN1 est de base (j'ai fait simple)

Il faudra ensuite configurer le port (par ex. le port #1) qui reçoit le câble en provenance du RB600A de façon a ce que le VLAN1 et le VLAN100 soit “TAGGED” (il réceptionne donc les paquets “marqué” par ces VLAN et les traites)

Le port (par exemple le port #2) sur lequel est connecté la Freebox HD devra avoir le VLAN100 “TAGGED” lui aussi

Tout les autres ports (donc de #3 a #8) devront avoir le VLAN1 en “UNTAGGED” et ne pas recevoir/gérer le VLAN100

Tester

Et voila, en allumant votre Freebox HD, le flux TV passe par votre réseau local et non plus par les antennes, il ne restera plus qu'a désactiver dans l'interface client de Free la désactivation totale du WiFi/MiMo.

C'était simple, mais j'ai perdu des neurones dans l'histoire :)

Prochaine étape utiliser un mediaplayer (ushare, mediatomb, ou même une PS3 - qui m'en prête une ? -) pour lire les video sur la Freebox HD

Discussion

Entrer votre commentaire
 
blog/freebox-hd_reseau-local_avec_rb600a_gs108t_vlan.txt · Dernière modification: Monday 07 June 2010 par toonnette
Flux RSS du Blog Driven by DokuWiki Gentoo Powered Valid XHTML1.0 Powered by Apache PHP Powered Coffee Powered